Verification is currently underway for the maintenance items.
Posted Mar 03, 2026 - 21:11 MST
In progress
Scheduled maintenance is currently in progress. We will provide updates as necessary.
Posted Mar 03, 2026 - 21:00 MST
Scheduled
Bug Fixes
DOR – Edit Reason Dropdown Enhancement Description of Update: Updates were made to improve flexibility when selecting edit reasons.
DOR – Driver History Error Handling Improvements Description of Update: Validation and error handling improvements were applied to the Driver History application to enhance user experience.
HCPF – Mapping Location Accuracy/Pin Interaction Description of Update: General mapping improvements
Maintenance
DOR – Agency List Update Description of Update: Added a new agency to the Agencies list
DOR – Driver History Logging Improvements Description of Update: Updates to improve logging
Security
HCPF – Administrative Session Management Description of Update: Enhancements were made to administrative session management
Posted Feb 27, 2026 - 07:43 MST
This scheduled maintenance affected: Custom Applications.