Scheduled maintenance is currently in progress. We will provide updates as necessary.
Posted Dec 02, 2025 - 21:00 MST
Scheduled
Bug Fixes
CBI – Cold Case Reporting Filter Update Description of Issue: An internal review identified an opportunity to improve how the Year Solved filter interprets user selections.
Description of Resolution: The filtering logic has been refined to better align with expected search behavior, ensuring more consistent and reliable results.
Courts E-Filing – Billing Notice Information Description of Issue: It was noted that billing notices could provide clearer information for users reviewing payment details.
Description of Resolution: Billing notices have been updated to include amount paid and amount due, providing more complete and easy-to-understand payment information.
Courts E-Filing – Email Notification Optimization Description of Issue: Email notification settings were reviewed and found to be sending more messages than necessary for certain account scenarios.
Description of Resolution: Notification rules have been adjusted to reduce unnecessary emails, creating a more streamlined communication experience.
Posted Nov 24, 2025 - 10:12 MST
This scheduled maintenance affected: Custom Applications.