Colorado Courts E-Filing Billing Issue - Investigating

Incident Report for DGS Colorado

Resolved

Incident Status: Resolved

We have confirmed that the issue has been resolved completely and all systems are operational at this time.

Incident start: [10/17/2025 10:33:00]
Incident end: [10/17/2025 13:27:00]
Components affected: [Custom Applications]

If you have any questions or concerns, please contact the Service Desk at 303-534-3468.

Thank you.

Colorado.gov Service Desk
Tyler Colorado
Managers of Colorado.gov
O - 303-534-3468
Posted Oct 17, 2025 - 13:28 MDT

Update

Incident Status: Identified

Our technical teams believe they have identified the issue and are continuing to actively work towards a resolution.
Please continue to use this workaround link to access this service in the meantime: https://secure.colorado.gov/apps/courts/billing/index.xhtml
We will provide another update shortly.

Components affected: [Custom Applications]

If you have any questions or concerns, please contact the Service Desk at 303-534-3468.

Thank you.

Colorado.gov Service Desk
Tyler Colorado
Managers of Colorado.gov
O - 303-534-3468
Posted Oct 17, 2025 - 13:03 MDT

Update

Incident Status: Identified

Our technical teams believe they have identified the issue and are continuing to actively work towards a resolution.
Please continue to use this workaround link to access this service in the meantime: https://secure.colorado.gov/apps/courts/billing/index.xhtml
We will provide another update shortly.

Components affected: [Custom Applications]

If you have any questions or concerns, please contact the Service Desk at 303-534-3468.

Thank you.

Colorado.gov Service Desk
Tyler Colorado
Managers of Colorado.gov
O - 303-534-3468
Posted Oct 17, 2025 - 12:38 MDT

Update

Incident Status: Identified

Our technical teams believe they have identified the issue and are continuing to actively work towards a resolution.
Please continue to use this workaround link to access this service in the meantime: https://secure.colorado.gov/apps/courts/billing/index.xhtml
We will provide another update shortly.

Components affected: [Custom Applications]

If you have any questions or concerns, please contact the Service Desk at 303-534-3468.

Thank you.

Colorado.gov Service Desk
Tyler Colorado
Managers of Colorado.gov
O - 303-534-3468
Posted Oct 17, 2025 - 12:06 MDT

Identified

Incident Status: Identified

Our technical teams believe they have identified the issue and are now actively working towards a resolution.
A workaround link has been provided to access this service in the meantime: https://secure.colorado.gov/apps/courts/billing/index.xhtml
We will provide another update shortly.

Components affected: [Custom Applications]

If you have any questions or concerns, please contact the Service Desk at 303-534-3468.

Thank you.

Colorado.gov Service Desk
Tyler Colorado
Managers of Colorado.gov
O - 303-534-3468
Posted Oct 17, 2025 - 11:28 MDT

Update

Incident Status: Investigating

We are still investigating issues affecting logging into the "Colorado Courts E-Filing" Application. Our teams are actively working to identify the root cause and resolve the issue as quickly as possible.
We will provide updates as soon as more information becomes available.
Thank you for your patience.

Components affected: [Custom Applications]

If you have any questions or concerns, please contact the Service Desk at 303-534-3468.

Thank you.

Colorado.gov Service Desk
Tyler Colorado
Managers of Colorado.gov
O - 303-534-3468
Posted Oct 17, 2025 - 11:03 MDT

Investigating

Incident Status: Investigating

We are currently investigating issues affecting logging into the "Colorado Courts E-Filing" Application. Our teams are actively working to identify the root cause and resolve the issue as quickly as possible.
We will provide updates as soon as more information becomes available.
Thank you for your patience.

Components affected: [Custom Applications]

If you have any questions or concerns, please contact the Service Desk at 303-534-3468.

Thank you.

Colorado.gov Service Desk
Tyler Colorado
Managers of Colorado.gov
O - 303-534-3468
Posted Oct 17, 2025 - 10:33 MDT
This incident affected: Payment Services.