PayPal Crypto Payment Option Unavailable

Incident Report for DGS Colorado

Resolved

The issue related to PayPal and crypto payments has been resolved. After working with PayPal and conducting testing, we’ve confirmed that PayPal Crypto is functioning as expected and is available as a payment option.

If any users continue to experience issues, please let us know by opening a ticket (https://coloradointeractive.atlassian.net/servicedesk/customer/portal/5). We’re happy to investigate further.
Posted Jun 30, 2025 - 11:23 MDT

Update

Our team is actively working with PayPal to resolve the ongoing issue related to the Crypto functionality. The matter has been escalated to their higher-level engineering team for further investigation.

We will continue to monitor progress closely and share updates as they become available.
Posted Jun 29, 2025 - 09:45 MDT

Investigating

We are currently investigating an issue where the crypto payment option is not appearing for users attempting to pay via PayPal. This issue has been confirmed to be on PayPal’s side, and they have opened a bug ticket to address it.

Please note that all other forms of payment remain fully available and operational.

We are actively monitoring the situation and will share updates as we receive them from PayPal.

Thank you for your patience and understanding.
Posted Jun 27, 2025 - 14:19 MDT
This incident affected: Payment Services.