Payments Issue - Investigating

Incident Report for DGS Colorado

Resolved

The issue impacting credit card payment processing at state and county DMV offices has been resolved, and services have returned to normal.
Posted Apr 24, 2026 - 12:59 MDT

Monitoring

We are seeing recovery in the DMV credit card payment processing delays and are continuing to monitor progress closely. We will continue to provide updates and monitor the situation,

If you have any questions or concerns, please contact the Service Desk at 303-534-3468.

Thank you.

Colorado.gov Service Desk
Tyler Colorado
Managers of Colorado.gov
O - 303-534-3468
Posted Apr 24, 2026 - 10:28 MDT

Investigating

Incident Status: Investigating

We are currently investigating a technical issue impacting credit card payment processing at all state and county DMV offices. Customers may experience delays when completing transactions. Our team is actively working to identify the cause. Updates will be provided as more information becomes available.


Components affected: [Payment Services]

If you have any questions or concerns, please contact the Service Desk at 303-534-3468.

Thank you.

Colorado.gov Service Desk
Tyler Colorado
Managers of Colorado.gov
O - 303-534-3468
Posted Apr 24, 2026 - 09:40 MDT
This incident affected: Payment Services.